Skip to content

FIPS - cannot disable in the runtime #505

Description

@mateBe95

Container platform

OCP 4

Version

ubi9/ubi-minimal:latest

OS version of the container image

RHEL 9

Bugzilla, Jira

No response

Description

In previous weeks it was possible to disable Node.js FIPS mode on fips enabled clusters at nodejs application runtime using crypto.setFips(false). However, this is no longer the case — calling this method now results in an error.

Cannot set FIPS mode. FIPS should be enabled/disabled at system level. See https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/9/html/security_hardening/assembly_installing-the-system-in-fips-mode_security-hardening for more details.
Error: Cannot set FIPS mode. FIPS should be enabled/disabled at system level. Seehttps://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/9/html/security_hardening/assembly_installing-the-system-in-fips-mode_security-hardening for more details.

Is there any way to solve this problem?

Reproducer

No response

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions